Enhanced security & improvements underway
Incident Report for Assembly
Resolved
The maintenance window has been successfully completed. Monitoring over the past couple of weeks indicates satisfactory performance. Thank you for your patience and cooperation during this time.
Posted Feb 28, 2024 - 05:12 UTC
Monitoring
The rewards system and other updates are operational, and we're currently monitoring the changes made.
Posted Feb 12, 2024 - 17:42 UTC
Investigating
We’re currently upgrading our rewards redemption system to bring you an even better experience. This includes enhancements to our platform’s security and functionality, ensuring a smoother and more secure process for redeeming your rewards.


The system is still under maintenance, but we’re working diligently to restore access as quickly and safely as possible.
We’re committed to not only resolving the accessibility of rewards but also to upgrading the overall system performance and security.


We’re aiming to provide a more detailed timeline for when you can expect full functionality to return. An update will be provided by the end of day 02/09/2024. We expect access to redemptions to be out over the weekend and resume on Monday, 02/12/2024.


For immediate concerns, please contact our support team at support@joinassembly.com. Thank you for your understanding as we enhance our systems to serve you better. We apologize for any inconvenience and are here to assist you through this period.
Posted Feb 09, 2024 - 22:35 UTC
This incident affected: Web.