Application: Template gallery not loading
Incident Report for Assembly
Postmortem

Summary

We had several users (internal and external) complain that the template gallery was not loading.

Impact

When users opened Template gallery it was in a loading state. Users were not able to select a template and create a new flow as a result.

Trigger

We got the incident communicated to us from the sales and support team.

Resolution

Users were advised to hard refresh the screen which loaded the template gallery.

Detection

We were unable to replicate the issue. On further analysis with our internal users who were affected, we realised the template gallery UI was not fetching the APIs.

Root causes

On further diagnosis, we found out that even after the new version of a Software bundle was pushed to browser clients to consume - the client was still pointing to the older version (usually cleared out after the new deployment).

The root cause was further tested in a lower environment. The team is looking into possible fixes for the future since it is not a recurring scenario.

Action items

Monitors were added for this in our logging application to alert the front-end team should an error recur.

Posted Apr 28, 2023 - 03:02 UTC

Resolved
We have resolved the incident. We recommend users hard refresh their browsers should you continue to experience issues while loading the template gallery.
Posted Apr 03, 2023 - 18:44 UTC
Investigating
We are currently investigating the issue.
Posted Apr 03, 2023 - 16:44 UTC
This incident affected: Web.