Assembly Degradation
Incident Report for Assembly
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 03:15 UTC
Identified
The issue has been identified and a fix is being implemented
Posted Nov 22, 2021 - 21:20 UTC
Investigating
Users have reported slowness in page loading time for some users. We are currently investigating the issue.
Posted Nov 22, 2021 - 16:24 UTC
This incident affected: Web.