Signing up to our services is momentarily unavailable
Incident Report for Assembly
Postmortem

Issue:
Previously, while making adjustments to the way we managed erroneous behaviour within our APIs, an unexpected behaviour emerged. This led users who were navigating to the OTP screen to be redirected back to the sign-up screen.

Bug Fix and Testing:
Based on our findings, we implemented corrective measures to restore the expected behaviour. Our Quality Assurance team rigorously verified the fix to ensure its effectiveness.

Preventive measures:
To prevent similar issues from occurring in the future, we have strengthened testing procedures. We have enhanced our testing protocols to encompass a wider range of scenarios to ensure thorough validation of the API error handling functionality.

Posted May 26, 2023 - 04:48 UTC

Resolved
This incident has been resolved.
Posted May 26, 2023 - 02:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted May 26, 2023 - 02:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 26, 2023 - 02:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2023 - 02:01 UTC
Investigating
Signing up to Joinassembly.com is unavailable at the moment. We are investigating the issue and a fix will be rolled out soon.
Posted May 26, 2023 - 01:36 UTC
This incident affected: Web.